Install Problem - Ordinal Not Found

[Deleted User][Deleted User]


I just download Serverscheck standard addition to try it out. It seems to be a great tool. When I try to run the installation file, it installs fine, but hwen it trys to the s-service.exe, it fails.

I get the message, The ordinal 2821 could not be located in the dynamic link library LIBEAY32.dll.

I have done a search, and I do have it in my system32 folder.

I'm running w2k server sp4.

I then try to launch serverscheck, and it tells me it can't run, and I need to install the services first.

Can you please tell me how to resolve this issue.

Thanks. Ton


  • AdministratorAdministrator
    What version are you using?
  • [Deleted User][Deleted User]

    I have the same problem. I try to install version 3.2.3. It gives me the error.

    The ordinal 2821 could not be located in the dynamic link library LIBEAY32.dll

    After installation it tells me to add the service. When i manually run it as task i get same error. Installatation is on windows2003 server.



  • evilguyevilguy
    This problem has been around for a long time. I asked about the same problem long ago. I have a feeling a lot of people get that same error and just abort the whole thing and nobody hears about it. Anyway, I hope they get that fixed.
  • AdministratorAdministrator
    The issue happens not on all platforms and depends on the other software installed on your computer.

    However we redesigned the software for release 4.4.0 which will no longer rely on that DLL.


    Forum Administrator
  • AdministratorAdministrator
    4.4.0 has been released and includes a fix that gets rid of that DLL (all checks that did depend on it have been recoded to not rely on it). On our internal tests everything works fine.

    Please confirm that it also works OK on your system.


    Forum Administrator
  • evilguyevilguy

    It works perfectly now. I was probably the most dedicated non-user you have. Until now I was unable to even try it out but I kept coming back to the forum to see if anything has changed. Now I can finally give it a try. Thanks for getting rid of that annoying install problem with that .dll. I know it was probably another .dll that was in conflict with it but tracking it down was impossible. Anyway, thanks.

  • AdministratorAdministrator
    No problem. and a big thank you for your patience.

    It took us a lot of time to get rid of it as it was part of the core of our system. So we had to rewrite quite a bit: in other words we did not forget you but it took longer than we expected.


    Forum Administrator
This discussion has been closed.