temp sensor not detected?

edited November 2007 in InfraSensing Sensors
Servers check software installed (v6.10.2),

just received a temp sensor with serial/rj45 cable.

started to add the device but the sensor isn't detected. i am getting a time out error (com 2) or unknown (com1) (only one com port)

any suggestions?

I have checked logs and tried sensor check from the command prompt - no good.

I have Dot 2 & 3 installed.

ws2k3 installed and updated.

any assistance is appreciated.



  • AdministratorAdministrator
    It is highly recommended to have the latest version of the monitoring software to use with sensors as there are many changes in sensor communication protocol compared to 6.10.2

    .NET 2 and .NET 3 won't work. As per sensor user manual this needs to be .NET 1.1

    Your UNKNOWN will be probably related to that issue. COM 1 appears to be the correct one but no .NET 1.1 installed
  • sberglundsberglund
    thanks, i will get .net 1.1 on,

    fyi - the manual doesn't say it needs to be (but should be) .net 1.1, it also states that .net 2 might give an error message but should work.

    the latest version, is it a free upgrade?
  • AdministratorAdministrator
    If you have a support & upgrades agreement, then you can upgrade to the latest release.

    The user manual stipulates that .NET 1.1 is required and that a specific error can be shown in .NET 2 It does not say that it works with .NET 2

    The monitoring of the sensors require the .NET 1.1 framework to be installed on the computer running the ServersCheck Monitoring Software. If you do not have .NET 1.1 installed but .NET 2.0 then you might receive following error message:


    If you read it somewhere else that does support .NET 2, then please kindly point out where so that we can correct it to avoid other customers facing the same issue.
  • sberglundsberglund
    i have upgraded to the latest version and license.

    status: down?

    error returned: the format of the file 'DesktopSerialIO' is invalid

    I did a quick search but haven't found any thing with this message.

  • AdministratorAdministrator
    You have probably not performed a correct upgrade as moving from 6.10.2 to 7.8.x requires a manual upgrade.

    Here is how to perform a manual upgrade:


    The last 2 topics will be removed as they are not linked to the initial post related to .NET 1.1
  • sberglundsberglund
    I have upgraded following the steps laid out.

    still not able to get sensor to work.

    com1 down?

    status unknown

    other com ports tried



    timout has occurred (com 2)

    unable to open com port (all other com ports)

    are there any com port settings that need to be changed? i didn't see anything in the user manual or else where that specified anything.

    will try different system Monday

    (have setup one before at a different location and it was pretty much plug n play.)
  • AdministratorAdministrator
    Run following from the command prompt in the agents subdirectory:

    sensor_check -L log.txt -C COM1

    (provided the sensor is connected to com port 1)

    What is the output?
This discussion has been closed.