Software Update


Is there a specific process I need to do to install the update? I am currently running the update as an Adminstrator and get the following error message. I am thinking the file is in use by one of the services so it denies any changes to the file. Are there any processes I need to stop prior to installing the update?

If I chose to ignore the message it proceeds with the install but it does not change the version within Program and Features and the flood mapping still does not work. I do not want to do a fresh install as I will have to redo all the notifications for the sensors we have in place. Please advise.

And thanks for being proactive on your own products.


  • AdministratorAdministrator
    What version of the software are you running? 14.3.4?

    Are you using the Monitoring Appliance?
  • ProTechProTech
    I am running 14.3.2.trying to upgrade to 14.3.4 to resolve the leak sensor mapping issue.

    I am not using the Monitoring Appliance just the licensed software on a Windows 10 Enterprise OS with 12GB of Ram and an i5 processor.
  • AdministratorAdministrator
    Make sure all services are stopped when performing the update. You can stop them via the Windows Services Manager. (Services.msc)
  • ProTechProTech
    I stopped the two services in the attachment. There were no errors during the installation but the monitoring software didnt update within programs and features and the leak maps feature is still not working.imageSERVERSCHECK SERVICES
  • PocholloPochollo
    Hey icisneros

    You can also do a re-install and just transfer your configuration over to the newly installed software.
    to be safe make a copy of the monitoring software folder (rename it as back up). though all you really need is the /data and /conf subdirectories.

    Uninstall the software and install the latest one from ServersCheck and restore the /data and /conf subdirectories to the newly installed software. restart your browser.

    This worked for me.. but make sure you have a back up
  • ProTechProTech
    Thanks I will give it a try.
  • ProTechProTech
    I had to completely uninstall the software and reinstall since it had already changed my notification settings not to send. Although they would still send out with "No Sender" although the settings stated not too. I would like to confirm if the software version under Programs and Features should show 14.3.2 or 14.3.4 because I completely uninstalled the sw and installed the new version but its still showing 14.3.2.
  • ProTechProTech
    I installed the new version on a new computer and it came up as 14.3.2.
  • AdministratorAdministrator
    When you go to Settings > License do you see 14.3.2 or 14.3.4 ?
  • ProTechProTech
    It is showing 14.3.2 on both the live server and the test machine that never had the sw before. I downloaded the file from the following link since theres two pages you offer the download.
  • ProTechProTech
    I went to the file location and it is showing 14.3.2. Can you test the installation youself? Also, I am wondering if the license has anything to do with it. Does it need a new version license?

  • ProTechProTech
    This whole update started with this thread.

    Its been 5 months since I reported the issue on your mapping feature in your software, something that was advertised to work. Can I get the licensed extended? I have tried setting up the features on the map with the new download available, and it still doesnt work.
  • AdministratorAdministrator
    You can download the s-server.exe component straight from this URL

    Double checked and this is version 14.3.4
  • ProTechProTech

    I was able to upgrade by going to upgrade.exe. I did notice 1 sensor missing so I will double check all of them and the notifications.I will try the leak map as well.
Sign In or Register to comment.